Support Case Creation

Incident Report for Servers Australia

Monitoring

We've identified the issue and implemented a fix to resolve it. Case creation is working normally again.
Posted Jul 12, 2025 - 11:50 AEST

Investigating

We've identified an issue preventing the creation of new support cases. Our team are investigating the issue now and hope to have it resolved shortly.
Posted Jul 12, 2025 - 10:45 AEST
This incident affects: Service Desk (MySAU Customer Portal).