Phone System Disruption – Upstream Provider Issue

Incident Report for Servers Australia

Resolved

This incident has been resolved.
Posted May 01, 2025 - 12:16 AEST

Monitoring

All affected phone services have been restored, and we are actively monitoring system performance to ensure continued stability.

If you have any further issues reaching Servers Australia by phone please raise a support case via the MySAU.com.au portal.
Posted May 01, 2025 - 11:21 AEST

Identified

We are currently experiencing disruptions with our phone systems due to issues with an upstream provider.

If you are unable to reach us via phone, please submit a support case at MySAU.com.au for assistance.
Posted Apr 30, 2025 - 12:00 AEST
This incident affected: Service Desk (Phone Support).