Tropical Cyclone Alfred – Impact on Equinix BR1 IBX Data Centre

Incident Report for Servers Australia

Resolved

Operations have returned to Normal at the BR1 Facility
Posted Mar 11, 2025 - 23:10 AEDT

Monitoring

Tropical Cyclone Alfred is currently positioned approximately 463 km (287 mi) east of Brisbane as a Category 2 cyclone.

Servers Australia is closely monitoring the situation and working with the Equinix team, particularly in relation to our infrastructure at the

Equinix BR1 IBX data centre. Equinix has assured us that they are in direct communication with local authorities and electricity vendors to ensure operational stability. The BR1 facility is equipped with dual Uninterruptable Power Supply (UPS) systems and N+1 block redundant configured generators, ensuring continued power availability. Additionally, Equinix has agreements in place with multiple fuel vendors to facilitate expedited fuel deliveries should the need arise.

As a precaution for staff safety, Servers Australia has pulled onsite resources from the data centre until further notice. We will assess the need for resources to attend the facility on a case-by-case basis and will only dispatch personnel if necessary.

At this stage, we do not anticipate disruptions to our services; however, we will continue to provide updates as necessary. Please monitor this status for updates on the situation.

Stay safe, Servers Australia Team
Posted Mar 05, 2025 - 12:29 AEDT
This incident affected: Regions (Brisbane) and Data Centres (Equinix BR1).