Servers Australia Portal Connectivity Issues

Incident Report for Servers Australia

Resolved

Engineers have since resolved the issues relating to MySAU Portal connectivity, customers will be able to access their accounts and Support ticketing systems as normal.

Customers who are still experiencing issues relating to this may need to clear their browser cache / use a Private Browsing session or alternative device, otherwise feel free to contact our Support team for assistance.
Posted Dec 10, 2025 - 13:44 AEDT

Investigating

Engineers are currently aware of connectivity issues affecting our MySAU / Servers Australia Customer Portal. Customers may have difficulty loading the pages and logging into their Servers Australia accounts.

Further updates will be provided as soon as possible
Posted Dec 10, 2025 - 12:47 AEDT
This incident affected: Service Desk (MySAU Customer Portal).