MySAU.com.au is currently unavailable

Incident Report for Servers Australia

Resolved

Our engineering team has implemented a fix, and the service has been fully restored.

We have completed monitoring and can confirm the issue is now resolved.

Thank you for your patience.
Posted Nov 21, 2025 - 19:00 AEDT

Monitoring

We are aware that mysau.com.au was previously unavailable.
Our engineering team has implemented a fix, and the service is now restored. We are continuing to closely monitor the platform to ensure stability.

Further updates will be provided if necessary.
Posted Nov 21, 2025 - 16:30 AEDT

Investigating

We are currently aware that mysau.com.au is unavailable.
Our engineering team is actively investigating the issue and working to restore service as quickly as possible.

Further updates will be provided as soon as more information becomes available.
Posted Nov 21, 2025 - 16:09 AEDT
This incident affected: Service Desk (MySAU Customer Portal).